Il est toujours conseillé de monter en version son instance Magento pour profiter, si ce n’est des nouvelles fonctionnalités, au moins des corrections de failles de sécurités. Mais c’est aussi valable pour PHP. C’est pourquoi Magento a été mis à jour afin d’être compatible avec php 5.4.

Un patch est fourni ici pour supprimer les problèmes que rencontre Magento CE à partir de la version 1.6 dans l’environnement php 5.4. Un autre patch a été fourni pour les versions Entreprise accesible directement depuis le compte client.

Si vous n’avez jamais appliqué de patch Magento vous fourni des explications ici.

Je ne vais pas ici lister les nouveautés et apports de php 5.4 (surtout que la version 5.5 est sortie depuis), d’autres l’ont fait par ailleurs et on peut trouver des informations sur le site de php bien sûr.